apache24 broken after change from lua to lua51?

olli hauer ohauer at gmx.de
Fri Jun 20 20:52:16 UTC 2014

On 2014-06-20 17:49, Peter Olsson wrote:
> Hello!
> After the change from lua to lua51, compilation of
> apache24 fails with this:
> checking for sqrt in -lm... yes
> checking for lua.h in /usr/local/include/lua5.1... no
> checking for lua.h in /usr/local/include/lua51... yes
> checking for luaL_newstate in -llua... no
> configure: WARNING: *** Lua 5.1 library not found.
> configure: error: Lua 5.1 library is required
> I have this installed:
> lua51-5.1.5_7                      =   up-to-date with index
> I even tried deinstallating lua and let apache24 drag it in,
> but that didn't help either.
> I'm using 9.2-RELEASE-p7 with pkgng, and installing with portmaster.

The httpd-2.4.x configure script self announce only support for lua5.1 (hard coded).
Anyway with the patch below the port builds even with lua5.2.

All messages containing lua will report lua5.1 even with lua5.2 because of the hard wired version.
After the build a check with the command should display the correct lua version.
$ ldd work/stage/usr/local/libexec/apache24/mod_lua*

Please test the following patch and report back if mod_lua is working.


More information about the freebsd-apache mailing list