Re: rtw88 import to main

From: Daniel_Pérez <>
Date: Sun, 03 Apr 2022 14:51:08 UTC
Update: after changing my interface settings, I finally got wifi (I had some problems with my wpa_supplicant config and the default route).
Managed to connect to my dual-band connection in mode 11g, getting around 7.3Mbps of download speed (which is very acceptable at this state).

Wifi seems to be stable, though when performing the speed test, the upload failed and got this in dmesg:

Limiting closed port RST response from 216 to 200 packets/sec

And when repeating it I got this message repeated numerous times (above 100):
rtw880: failed to write TX skb to HCI

Still had connection, though.

All this was done limiting memory to 4G.

Finally seeing some light in the tunnel.

------- Original Message -------
On Friday, April 1st, 2022 at 3:56 PM, Bjoern A. Zeeb <> wrote:

> On Fri, 1 Apr 2022, Daniel Pérez wrote:
> > Thank you for the hint. Kernel built without an issue.
> > As expected, part of the firmware fails to load without the physmem hint (7200MB). I tried to boot with physmem set to 4G, firmware loaded and I could attach rtw880 to a new wlan device.
> Thanks a lot for testing and the feedback. Very helpful to know that
> it's same symptoms elsehwere. Much appreciated.
> Did you also try to bring the wlan up when you had liimted memory and
> creating wlan0 worked?
> Lots of health,
> Bjoern
> --
> Bjoern A. Zeeb r15:7