Re: Unable to run any KDE applications

From: Michael Schuster <>
Date: Wed, 23 Feb 2022 06:20:56 UTC
On Wed, Feb 23, 2022 at 6:58 AM Freddie Cash <> wrote:

> System was running 12.1 without issues, with a full install of KDE 5.
> Did an upgrade to 12.2.  Everything was still working.
> Did a "pkg update/pkg upgrade" to the latest quarterly ... and now no KDE
> applications will run.  Running anything gives the following error:
> /usr/local/lib/ Undefined symbol
> "_ZNSt19bad_optional_accessD1Ev"

unmangled, this is "std::bad_optional_access::~bad_optional_access()",
so it looks like something with the libc++ you have on your system is out
of sync with the rest (this from a short search, I don't know much more
about that stuff ... )


> Thinking it might be an issue with the quarterly package builds, I
> switched pkg to use the latest repo.  Did a forced upgrade to make sure
> everything was re-installed.  Same error.
> Did an upgrade to 13.0.  Force upgraded all pkgs again.  Same error.
> Manually uninstalled all KDE frameworks pkgs and installed them fresh.
> Same error.
> Unfortunately, even though this is running on a ZFS pool, I didn't
> snapshot the /usr/local filesystem, so I can revert to a working system.  :(
> Haven't tried building from the ports tree directly yet or trying to
> figure out poudriere.  Hoping to avoid that if possible (been using
> strictly the official binary packages for several years now).
> Has anyone else come across this error message when using the latest or
> quarterly KDE packages?
> --
> Freddie Cash

Michael Schuster
recursion, n: see 'recursion'