Re: FreeBSD boot problem with Intel Atom C5000 Parker Ridge

From: Jan Bramkamp <>
Date: Wed, 11 Oct 2023 14:54:00 UTC
On 28.07.23 11:31, Thomas Niedermeier wrote:
> Hi,
> I'm writing you about some issue I had while testing a Atom SoC Board.
> It is equipped with the new generation Intel C5000 Parker Ridge series.
> In this specific case the Intel Atom Processor C5315.
> When you boot from a FreeBSD-based OS flash drive, it always runs in 
> live mode.
> I think you might know ;)
> After a couple of seconds the boot process stops and a specific screen 
> appears.
> The screenshot is located here: 
> Thats the only output I have, because the system stops immediately 
> afterwards.
The screenshot shows the FreeBSD kernel running. Hardware enumeration 
has finished. The kernel tried to mount the root file system and failed. 
If the keyboard (USB, PS/2, IPMI KVM) works type a question mark 
followed by enter to get a list of all devices.
> We already did hours of research, trying different "solutions" from 
> the forums.
> But unfortunately no chance to get it working.
> Following tweaks we already tried:
> What we tested:
> First we tested an OPNsense 23.1 installer media flashed to a USB 3.0 
> drive.
> Afterwards also on a USB 2.0 flash drive, UEFI mode.
> Image: 
> We also tried mounting it with the IPMI console from that specific SoC 
> motherboard.
> Finally we also tested FreeBSD 13.2 and FreeBSD 14.0 Current.
> Following Image was used: 

The most likely explanation is that the USB controller you've connected 
to isn't working under FreeBSD. You can get this far in the boot process 
because the bootloader uses the UEFI or BIOS drivers to read from disks. 
There may be multiple USB controllers on the board. It's worth trying 
all ports because it would be a lot easier to debug if you can install. 
If the board has IPMI storage emulation you may be able to boot from it. 
If USB 2.0 is working an old USB extension cable or hub could be enough 
to install. If at least one NIC and SATA or NVMe are working you could 
at least boot into a VM image dumped on a disk. Of course a system 
without working USB is heavily restricted, but if you have a full 
FreeBSD installation available further troubleshooting would be a lot 

> Every other Operating System runs fine (Ubuntu, Debian etc).
> But unfortunately all FreeBSD-based solutions seem to have the similar 
> issue.
> We don't have a clue what the reason could be with FreeBSD-based 
> Operating Systems.
> The testing was in early May, so with thelatest FreeBSD 14-Current 
> back then.
> Maybe the 14-Current code is different now.
FreeBSD has it's own USB stack and drivers. My suspicion is on the USB 
controller driver. Have you already restored the UEFI/BIOS settings to 
default and just systematically toggled through combinations like USB 
boot emulation and handoff setttings?