FreeBSD boot problem with Intel Atom C5000 Parker Ridge

From: Thomas Niedermeier <>
Date: Fri, 28 Jul 2023 09:31:22 UTC

I'm writing you about some issue I had while testing a Atom SoC Board.
It is equipped with the new generation Intel C5000 Parker Ridge series.
In this specific case the Intel Atom Processor C5315.

When you boot from a FreeBSD-based OS flash drive, it always runs in live mode.
I think you might know ;)
After a couple of seconds the boot process stops and a specific screen appears.
The screenshot is located here:

Thats the only output I have, because the system stops immediately afterwards.

We already did hours of research, trying different "solutions" from the forums.
But unfortunately no chance to get it working.
Following tweaks we already tried:

What we tested:
First we tested an OPNsense 23.1 installer media flashed to a USB 3.0 drive.
Afterwards also on a USB 2.0 flash drive, UEFI mode.
We also tried mounting it with the IPMI console from that specific SoC motherboard.
Finally we also tested FreeBSD 13.2 and FreeBSD 14.0 Current.
Following Image was used:

Every other Operating System runs fine (Ubuntu, Debian etc).
But unfortunately all FreeBSD-based solutions seem to have the similar issue.
We don't have a clue what the reason could be with FreeBSD-based Operating Systems.
The testing was in early May, so with thelatest FreeBSD 14-Current back then.
Maybe the 14-Current code is different now.

Thanks and best regards,