[Bug 270506] Unable to reach loader menu with 13.2-RCx ISOs on amd64

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 28 Mar 2023 20:28:09 UTC

            Bug ID: 270506
           Summary: Unable to reach loader menu with 13.2-RCx ISOs on
           Product: Base System
           Version: 13.2-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: misc
          Assignee: bugs@FreeBSD.org
          Reporter: kraileth@elderlinux.org

Created attachment 241166
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=241166&action=edit
Example of the EFI output

I've noticed that I'm unable to boot FreeBSD when using the latest RC ISO
images for 13.2 on amd64 (i.e. FreeBSD-13.2-RC5-amd64-disc1.iso). The problem
is fully reproducible on multiple machines both with BIOS and EFI. On the
former I end up only getting a blinking cursor instead of the expected beastie
menu, on EFI systems I get more information (see attached file).

The ISO image for i386 is not affected and neither is the amd64 memstick
version. I have tried out -RC4, too, and it shows the same behavior. Also got
-RC3 and -RC2 from a mirror that was not up to date and they are affected as
well. The only older ISO that I still had is -BETA1 - and that one boots just

I've posted about this on Reddit, asking if anybody kept older ISOs and some
people have tried to reproduce my problem without success. The important
information here may be that I'm using a USB CD emulator (the iodd-2531 to be

I cloned the source and checked out the various commits of releng/13.2 when new
betas or RCs happened, built the system and ran "make cdrom" to test the ones
that I couldn't get from the net. After doing so, my conclusion was that
something broke between -BETA1 and -BETA2. This conclusion was wrong, though:
For good measure I built the last known good one myself, too, and ended up with
an ISO showing the broken behavior! I'm really not sure what is happening here.

A little more context: I ran into a similar problem before when testing a
snapshot of MidnightBSD 3.0 a while ago. After I reported the problem, a new
ISO was rolled and I was asked to try that. It worked just fine. So yesterday I
asked Lucas Holt of MidnightBSD what he had done back then. It seems he found
that something had been truncated even though the machine had plenty of space
available. Eventually he just ran "make clean" in /usr/src/release before
building a new ISO and that fixed it in his case. So there was no code change

I just tried out running "make clean" and then "make cdrom" again with the
already compiled -BETA1 code. Unfortunately the resulting ISO still is corrupt.
Then I tried out the latest -CURRENT snapshot and found that also unable to get
to the loader menu...

I'm currently almost out of ideas on how to narrow this issue down. If anybody
has any suggestions, I'll be happy to try them out. Also always willing to
provide more info if that could be useful (since the problem happens on all
machines that I tested the ISOs with I did not attach a dmesg or output of
dmidecode, but I of course could).

Unless somebody proposes another strategy, I'll wipe the test machine and try
building -BETA1 again cleanly and without using ccache to see if I can get a
working ISO built.

You are receiving this mail because:
You are the assignee for the bug.