[Bug 269912] nvmecontrol ns create command fails on FreeBSD 13.1

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 02 Mar 2023 11:03:08 UTC

            Bug ID: 269912
           Summary: nvmecontrol ns create command fails on FreeBSD 13.1
           Product: Base System
           Version: 13.1-RELEASE
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: bin
          Assignee: bugs@FreeBSD.org
          Reporter: florian.millet@laposte.net

Created attachment 240526
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=240526&action=edit
Linux output for nvme id-ctrl

All the tests were made on SAMSUNG MZWLJ15THALA-00007 15TB NVMe drives on
FreeBSD 13.1 (see attachments for nvmecontrol identify outputs).

Trying to create a namespace with nvmecontrol do not work with the command :
# nvmecontrol ns create -s 117194752 -c 117194752 -f 2 nvme0
nvmecontrol: namespace creation failed: Invalid Field

I tried different combinations of parameters, nothing works, even with a bare
minimal command ns create fails.

In comparison, the same command works fine on Linux :
root@rescue:~# nvme create-ns -s 117194752 -c 117194752 -f 2 /dev/nvme0
create-ns: Success, created nsid:1

All other ns commands worked normally (delete, detach, etc ...), only the
create command fails.

These commands were tested on nda drivers, I do not think nvd drivers would
change anything, it seems to be nvmecontrol that do not build the correct
command to the NVMe controller.

You are receiving this mail because:
You are the assignee for the bug.