System Fails to Boot (Deadlock?)

Brandon Falk falkman at
Thu Jul 14 01:38:06 UTC 2011

On 7/13/2011 8:14 PM, Brandon Falk wrote:
> On 7/13/2011 10:58 AM, John Baldwin wrote:
>> On 7/13/11 9:37 AM, Brandon Falk wrote:
>>> On 7/13/2011 6:49 AM, John Baldwin wrote:
>>>> On Tuesday, July 12, 2011 6:10:05 pm Brandon Falk wrote:
>>>>> Hello,
>>>>> My machine somehow fails to boot into FreeBSD (off the cd, since it
>>>>> fails to boot, I can't install it in the first place). It goes 
>>>>> through
>>>>> and ends up stopping deadlock style. No printouts of errors 
>>>>> (besides a
>>>>> ppc problem, which is not fatal) and no crash/oops/panic. It just...
>>>>> stops and locks up. I know my motherboards PCI system has failed, as
>>>>> well as lan (getting a new one tomorrow), which is probably what is
>>>>> causing the problem. The thing is that Windows 7 and Linux happen to
>>>>> boot just fine on my machine, so although my system has a failing
>>>>> motherboard and may cause errors, I still feel like it shouldn't be
>>>>> causing this much of an issue on boot. I tried verbose logging and 
>>>>> got
>>>>> no more information anyways. It will be nearly impossible to diagnose
>>>>> this error so I'm looking for tips on where to look.
>>>> How far does it get when it locks? Is it able to load /boot/loader off
>>>> of the CD ok? Is it getting into the kernel far enough to output stuff
>>>> to the
>>>> console? Is it getting into sysinstall and hanging at some sysinstall
>>>> screen?
>>>> Also, is this host on the network and able to PXE? It's a lot easier
>>>> to test
>>>> custom kernels if needed using PXE than CDs (no need to burn a new CD
>>>> each
>>>> time, etc.).
>>> Since it's on a native box, I have no good way of copying the text, so
>>> perhaps later I'll copy it by hand. /boot/loader launches just fine, 
>>> and
>>> it's outputting messages just fine, until it just halts. It does not 
>>> hit
>>> sysinstall. This box also does not have net as LAN is shot on the
>>> motherboard (hence getting the new motherboard).
>> What is the last message it outputs before it hangs?
> Hello,
> Sorry, I've been busy with work and I can't be bothered with rebooting 
> my machine right now. But, it seems I have duplicated a very similar 
> issue under a VM. Under the 9.0-CURRENT-201105-amd64-bootonly.iso iso 
> it 'locks' up during boot with yet again no error message or crash. 
> This only seems to happen when 8 cores are allocated to the VM, 
> everything is just fine and dandy with 4, 2, or 1 core(s). (Note, on 
> my native box I was using the 8.2-RELEASE amd64 bootonly iso).
> On the VM the last messages I get are:
> SMB: AP CPU #x Launched!
> x being a number inclusive and between 1-7, in a random order 
> (obviously the cpus start at 'random' times).
> I cannot duplicate this error on a successfully installed 
> FreeBSD-8.2-RELEASE-amd64 using the same hardware settings.
> Hmm, I just thought perhaps it is a CD issue... I tried 
> FreeBSD-8.2-RELEASE-amd64-bootonly on 8, 4, 2, and 1 cores, and it 
> seems to work just fine... argh.
> -Brandon


Sorry for spamming out more and more messages, but I noticed another 
pattern in the VM. It happens to fail sometimes even on 4 cores, it 
seems to be COMPLETELY random (ugh...), in the matter that one time it 
will boot, I'll do nothing but hit 'reboot', then it will work, then it 
wont, then it will, etc. I am not making any modifications to the system 
or hardware, it just seems to be completely random. I bet that sometime 
I may be able to get it to boot in a kernel with even 8 cores, but the 
randomness would make it very hard to do so. I'll try to get more 
information when I get back soon. Give me a heads up if this problem 
seems to be a common issue or something I may be overlooking. I'm 
anticipating putting FreeBSD on my main machine, but since I have 12 
cores on my main machine, I don't think it will boot any time soon...


More information about the freebsd-hackers mailing list