System Fails to Boot (Deadlock?)

Garrett Cooper yanegomi at
Thu Jul 14 01:38:28 UTC 2011

On Wed, Jul 13, 2011 at 6:14 PM, Brandon Falk <falkman at> wrote:
> On 7/13/2011 10:58 AM, John Baldwin wrote:
>> On 7/13/11 9:37 AM, Brandon Falk wrote:
>>> On 7/13/2011 6:49 AM, John Baldwin wrote:
>>>> On Tuesday, July 12, 2011 6:10:05 pm Brandon Falk wrote:
>>>>> Hello,
>>>>> My machine somehow fails to boot into FreeBSD (off the cd, since it
>>>>> fails to boot, I can't install it in the first place). It goes through
>>>>> and ends up stopping deadlock style. No printouts of errors (besides a
>>>>> ppc problem, which is not fatal) and no crash/oops/panic. It just...
>>>>> stops and locks up. I know my motherboards PCI system has failed, as
>>>>> well as lan (getting a new one tomorrow), which is probably what is
>>>>> causing the problem. The thing is that Windows 7 and Linux happen to
>>>>> boot just fine on my machine, so although my system has a failing
>>>>> motherboard and may cause errors, I still feel like it shouldn't be
>>>>> causing this much of an issue on boot. I tried verbose logging and got
>>>>> no more information anyways. It will be nearly impossible to diagnose
>>>>> this error so I'm looking for tips on where to look.
>>>> How far does it get when it locks? Is it able to load /boot/loader off
>>>> of the CD ok? Is it getting into the kernel far enough to output stuff
>>>> to the
>>>> console? Is it getting into sysinstall and hanging at some sysinstall
>>>> screen?
>>>> Also, is this host on the network and able to PXE? It's a lot easier
>>>> to test
>>>> custom kernels if needed using PXE than CDs (no need to burn a new CD
>>>> each
>>>> time, etc.).
>>> Since it's on a native box, I have no good way of copying the text, so
>>> perhaps later I'll copy it by hand. /boot/loader launches just fine, and
>>> it's outputting messages just fine, until it just halts. It does not hit
>>> sysinstall. This box also does not have net as LAN is shot on the
>>> motherboard (hence getting the new motherboard).
>> What is the last message it outputs before it hangs?
> Hello,
> Sorry, I've been busy with work and I can't be bothered with rebooting my
> machine right now. But, it seems I have duplicated a very similar issue
> under a VM. Under the 9.0-CURRENT-201105-amd64-bootonly.iso iso it 'locks'
> up during boot with yet again no error message or crash. This only seems to
> happen when 8 cores are allocated to the VM, everything is just fine and
> dandy with 4, 2, or 1 core(s). (Note, on my native box I was using the
> 8.2-RELEASE amd64 bootonly iso).
> On the VM the last messages I get are:
> SMB: AP CPU #x Launched!
> x being a number inclusive and between 1-7, in a random order (obviously the
> cpus start at 'random' times).
> I cannot duplicate this error on a successfully installed
> FreeBSD-8.2-RELEASE-amd64 using the same hardware settings.
> Hmm, I just thought perhaps it is a CD issue... I tried
> FreeBSD-8.2-RELEASE-amd64-bootonly on 8, 4, 2, and 1 cores, and it seems to
> work just fine... argh.

    Ok -- this sounds familiar. I saw something like that with the May
FreeBSD CURRENT USB snapshot on an r710, but things worked after I
properly configured the LSI RAID volume on the machine.

More information about the freebsd-hackers mailing list