svn commit: r216295 - in head/usr.sbin/bsnmpd: . tools tools/bsnmptools tools/libbsnmptools

Shteryana Shopova syrinx at
Sun Dec 12 18:43:50 UTC 2010


The attached patch worked.

The output of readelf with the patch is in the, the file also contains
the output of readelf main.o without the patch and with gcc. The
output of readelf bsnmpd compiled with clang and gcc is in . I hope this


On 12/12/10, Dimitry Andric <dim at> wrote:
> On 2010-12-11 16:42, Shteryana Shopova wrote:
>> This is now fixed. However I wouldn't expect bsnmpd(1) compiled with
>> clang to work - it didn't run last time I checked several months ago,
>> and I still get the same error -
>> udo /usr/sbin/bsnmpd -d -c /root/snmpd.config
>> snmpd[80050]: lm_load: open /usr/lib/ Undefined symbol
>> "oid_zeroDotZero"
>> snmpd[80050]: init dep failed: 13
>> snmpd[80050]: error in config file
>> bsnmpd(1) uses export-dynamic flag
> Can you please try the attached patch, which makes clang pass the
> -export-dynamic flag to the linker properly?

More information about the svn-src-all mailing list