svn commit: r216295 - in head/usr.sbin/bsnmpd: . tools tools/bsnmptools tools/libbsnmptools

Dimitry Andric dim at
Sun Dec 12 15:18:38 UTC 2010

On 2010-12-11 16:42, Shteryana Shopova wrote:
> This is now fixed. However I wouldn't expect bsnmpd(1) compiled with
> clang to work - it didn't run last time I checked several months ago,
> and I still get the same error -
> udo /usr/sbin/bsnmpd -d -c /root/snmpd.config
> snmpd[80050]: lm_load: open /usr/lib/ Undefined symbol
> "oid_zeroDotZero"
> snmpd[80050]: init dep failed: 13
> snmpd[80050]: error in config file
> bsnmpd(1) uses export-dynamic flag

Can you please try the attached patch, which makes clang pass the
-export-dynamic flag to the linker properly?
-------------- next part --------------
diff --git a/usr.sbin/bsnmpd/bsnmpd/Makefile b/usr.sbin/bsnmpd/bsnmpd/Makefile
index f7e9b23..80b14e2 100644
--- a/usr.sbin/bsnmpd/bsnmpd/Makefile
+++ b/usr.sbin/bsnmpd/bsnmpd/Makefile
 LDADD=	-lbegemot -lbsnmp -lwrap
-LDFLAGS= -export-dynamic
+LDFLAGS= -Wl,-export-dynamic
 .if ${MK_OPENSSL} != "no"

More information about the svn-src-all mailing list