Xorg not starting: no screens found (intel driver + i3-4130T)

Kevin Oberman rkoberman at gmail.com
Sun Mar 26 18:41:23 UTC 2017

On Sun, Mar 26, 2017 at 10:52 AM, Theron <theron.tarigo at gmail.com> wrote:

> On 03/26/17 07:28, - - wrote:
>> Hello Conrad & All,
>> Thank you for the quick response.
>> Running `sysctl kern.vty` suggested that vt was being used. However,
>> clearly something was not right bases on the log section that you
>> highlighted, so I added `kern.vty=vt` to `/boot/loader.conf` and that has
>> partially resolved the problem!
>> I also added `kld_list="i915kms.ko"` to `/etc/rc.conf` and removed my
>> xorg.conf file...
>> I am now getting `AIGLX: Screen 0 is not DRI2 capable`. (Please see
>> Xorg.0.log below...)
>> `glx info | grep Device` indicates that llvmpipe is being used
>> in contrast (on my Lubuntu partition, that I am using as a stop-gap
>> measure) I get:
>> `glx info | grep Device` outputs `MESA DRI Intel (R) Haswell (0x41e)`
>> If I specify to the intel driver, I get the no screens message that I
>> mentioned previously. (I have tried with both the intel driver config
>> snippet below and without it.)
>> Section "Device"
>>      Identifier "Card0"
>>      Driver "intel"
>> EndSection
>> I have spent some time RTM and searching through the forums, but have
>> been unable to solve the follow-up problem as of yet.
>> Some of the forum posts seemed to suggest it was something to do with
>> device permissions but my regular user is added to the video and wheel
>> groups.
>> Another thing I tried was restricting the resolution to 1920x1080 and
>> below because I read that resolutions greater than this could be
>> problematic.
>> I have tried connecting to my monitor with various cables, just in case
>> that was an issue...
>> Could anyone help with this stage of the troubleshooting process?
>> Thank you & regards,
>> Matthew
> Is `kld_list="i915kms.ko"` correct?  I have simply [...]" i915kms" (no
> extension).
> Make sure i915kms is indeed loaded:
> `kldstat` | grep i915`
> If this is indeed the problem and you do not want to reboot just to apply
> the change in rc.conf, load the module manually:
> `kldload i915kms`
> "No devices detected" indicates that Xorg cannot communicate with the
> module responsible for the GPU hardware.  It has nothing to do with regular
> user permissions or monitor connectivity.  Xorg on a headless system with a
> working GPU but no display outputs would be expected to give a "no screens"
> error but shouldn't have any problem finding the (GPU) device.
> Theron

And, while this is almost certainly not the primary issue, be sure that
only the KMS driver is loaded. You should not have i915.ko loaded. I think
this has been fixed, but it has been an issue with the latest version
Kevin Oberman, Part time kid herder and retired Network Engineer
E-mail: rkoberman at gmail.com
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683

More information about the freebsd-x11 mailing list