x11/nvidia-driver and CURRENT: update results in full fan blow on MSI GTX 960 Gaming 4G

O. Hartmann ohartman at zedat.fu-berlin.de
Sat Jun 4 12:52:32 UTC 2016

Three months ago I purchased a new GPU to replace a non-UEFI capable GTX560 Ti (MSI). The
choice was the MSI GTX 960 Gaming 4G. Apart from the part, that this GPU doesn't show the
performance boost on FreeBSD CURRENT, even with the most recent BLOB from nVidia, 367.18,
I realized that after the update from FreeBSD 11-CURRENT r300830 to r300956 (I guess,
Forgot the exact revision number, but it was > 300950), the fans of that specific GPU
blow at full speed when xdm/Xorg server has been started. This is annoying, since the
noise is incredible.

I tried to recompile the whole ports xorg relies on via

portmaster -df xorg xdm

hoping, that some sort of bug or API incompatibility could have caused the problems, but
that wasn't at all the case.

I run now r301300 and the "problem" is still present.

The environmental conditions did not change - not in a way that the full speed fan of the
GPU could be explained by raised temperatures of the environment. I tried to find via
Google some help, but it seems that I'm the first and only one having this problem,
especially with FreeBSD and this type of GPU. I also tried the official supported
x11/nvidia-driver (346.96 and the proposed 364.19) with no success.

Below, You will find some data I picked up from the kernel environment (if there are
other ways, please tell me) and the logfile of Xorg/X server.

hw.nvidia.gpus.0.type: PCIe
hw.nvidia.gpus.0.uuid: GPU-85fde95a-7974-9962-f1a4-d7c164413929
hw.nvidia.gpus.0.irq: 270
hw.nvidia.gpus.0.model: GeForce GTX 960
hw.nvidia.registry.TCEBypassMode: 0
hw.nvidia.registry.MemoryPoolSize: 0
hw.nvidia.registry.EnablePCIeGen3: 1
hw.nvidia.registry.CheckPCIConfigSpace: 4294967295
hw.nvidia.registry.RegisterForACPIEvents: 1
hw.nvidia.registry.MapRegistersEarly: 0
hw.nvidia.registry.EnableMSI: 1
hw.nvidia.registry.UsePageAttributeTable: 4294967295
hw.nvidia.registry.InitializeSystemMemoryAllocations: 1
hw.nvidia.registry.UpdateMemoryTypes: 4294967295
hw.nvidia.registry.DeviceFileMode: 438
hw.nvidia.registry.DeviceFileGID: 0
hw.nvidia.registry.DeviceFileUID: 0
hw.nvidia.registry.ModifyDeviceFiles: 1
hw.nvidia.registry.RmLogonRC: 1
hw.nvidia.registry.ResmanDebugLevel: 4294967295
hw.nvidia.registry.Mobile: 4294967295
hw.nvidia.version: NVIDIA UNIX x86_64 Kernel Module  367.18  Mon May 16 18:13:16 PDT 2016
dev.nvidia.0.%parent: vgapci0
dev.nvidia.0.%driver: nvidia
dev.nvidia.0.%desc: GeForce GTX 960

Hopefully someone can give some hints what could trigger the problem ...

Thanks in advance and please CC me (due to not subscribing this list).

Kind regards,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freebsd.org/pipermail/freebsd-x11/attachments/20160604/4d544841/attachment.sig>

More information about the freebsd-x11 mailing list