Radeon Mobility 9700 hangs on FreeBSD

Robert Noland rnoland at FreeBSD.org
Sat Sep 12 10:52:56 UTC 2009

On Fri, 2009-09-11 at 22:12 +0100, Pedro Azevedo wrote:
> Hi there,
> I installed FreeBSD, and PC-BSD as well, and when I try starting X the
> screen just goes black and the CPU usage increases a lot, I can't use any
> keys, I tried ctrl+alt+f1 but the screen remained black, I had to power down
> the computer to get it to reboot.
> I tried this on FreeBSD 7.x and 8.x and the results were the same. However
> on Linux there were no problems. (Ubuntu, Mint, Fedora, OpenSuse, Mandriva,
> CentOS)
> I tried getting some help on Freenode, and someone told me the problem could
> be FreeBSD's DRM implementation and directed me to this mailling list for a
> possible solution.
> I realize this isn't the most extensive bug report, but I wasn't able to get
> a Xorg.log, still if you can help it's appreciated.

The drm code that we ship is nearly identical to linux and the 9700
should be fine.  I would start by getting back to basics...  Verify your
xorg.conf and try just running startx from console.  If this is an AGP
chip, you can try forcing PCI mode or changing the AGPMode option.
IIRC, the default is now 1x.  Without any logging it is really hard to
guess what might be going on.


> Regards,
> Pedro Azevedo
> _______________________________________________
> freebsd-x11 at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-x11
> To unsubscribe, send any mail to "freebsd-x11-unsubscribe at freebsd.org"
Robert Noland <rnoland at FreeBSD.org>

More information about the freebsd-x11 mailing list