Radeon Mobility 9700 hangs on FreeBSD

Adam K Kirchhoff adamk at voicenet.com
Fri Sep 11 23:36:18 UTC 2009

On Friday 11 September 2009 17:12:52 Pedro Azevedo wrote:
> Hi there,
> I installed FreeBSD, and PC-BSD as well, and when I try starting X the
> screen just goes black and the CPU usage increases a lot, I can't use any
> keys, I tried ctrl+alt+f1 but the screen remained black, I had to power
> down the computer to get it to reboot.
> I tried this on FreeBSD 7.x and 8.x and the results were the same. However
> on Linux there were no problems. (Ubuntu, Mint, Fedora, OpenSuse, Mandriva,
> CentOS)
> I tried getting some help on Freenode, and someone told me the problem
> could be FreeBSD's DRM implementation and directed me to this mailling list
> for a possible solution.
> I realize this isn't the most extensive bug report, but I wasn't able to
> get a Xorg.log, still if you can help it's appreciated.

Did you attempt to start X with DRI disabled in your /etc/X11/xorg.conf as I 

If not, in the Modules section of your xorg.conf file, add these two lines:

Disable "dri"
Disable "dri2"

And then try again.  If X then works (as I suspect it will) we will have at 
least narrowed down the problem to the DRM.


More information about the freebsd-x11 mailing list