Problems With xorg 7.2

Tim Daneliuk tundra at
Tue May 29 17:09:25 UTC 2007

Firas Kraiem wrote:
> On Tuesday 29 May 2007 07:14:18 Tim Daneliuk wrote:
>> System:  FreeBSD 6.2-STABLE i386 SMP
>> MOBO:    Intel 946GZIS + 3.2Ghz Pentium D + 2G memory
>> I just finally managed to muddle through the upgrade to xorg 7.2.
>> (Though not noted in the docs in /usr/ports/UPDATING, I had to
>> do a 'make install' for /usr/ports/x11/xorg to get the installation
>> to complete after the upgrade.  Without this step, I had no video,
>> mouse, or keyboard drivers.  I had installed X originally from the
>> 6.2-RELEASE CD so I guess I assumed - wrongly - that the upgrade
>> would pickup everything needed.  Is this normal or did I miss a
>> step somewhere along the way?)
> Well, unless I'm terribly mistaken, this _is_ mentioned in UPDATING :
> "Make sure you have the x11/xorg meta-port installed."

Yes, it is.  I misunderstood this to mean that the xorg metaport
had to be installed *before* the update - that is, that X be fully
installed as of the last version.  My bad ;)

>> Three problems remain:
>> 1) After doing the portupgrades as explained in the doc, I ran it
>>     one last time to make sure all was well and saw this:
>>     Stale dependency: xf86-input-acecad-1.1.0 --> xkeyboard-config-0.9_2
>>     -- manually run 'pkgdb -F' to fix, or specify -O to force.
>>     Is this significant and/or what causes it/fixes it?  I am new
>>     to portupgrade, having always done this sort of thing by hand
>>     in the past.
> When this happens to me, I just run pkgdb -F as suggested and it installs the 
> missing dependency with no problems.

I tried that as well.  It seems that the port in question has a broken makefile.  I've not
had time to dig through it to figure out where a fix is needed, but it looks simple enough:

rm -f /usr/local/share/X11/xkb/compiled
rm: /usr/local/share/X11/xkb/compiled: is a directory
gmake[3]: *** [install-compiled] Error 1
gmake[3]: Leaving directory `/usr/ports/x11/xkeyboard-config/work/xkeyboard-config-0.9'
gmake[2]: *** [install-data-am] Error 2
gmake[2]: Leaving directory `/usr/ports/x11/xkeyboard-config/work/xkeyboard-config-0.9'
gmake[1]: *** [install-am] Error 2
gmake[1]: Leaving directory `/usr/ports/x11/xkeyboard-config/work/xkeyboard-config-0.9'
gmake: *** [install-recursive] Error 1
*** Error code 2

Stop in /usr/ports/x11/xkeyboard-config.
*** Error code 1

Stop in /usr/ports/x11/xkeyboard-config.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portinstall.29233.0 env make reinstall
** Fix the installation problem and try again.
** Listing the failed packages (*:skipped / !:failed)
        ! x11/xkeyboard-config  (install error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
Command failed [exit code 1]: /usr/local/sbin/portinstall x11/xkeyboard-config

Thanks for your time and interest ...

More information about the freebsd-x11 mailing list