Error in upgrading xorg (no metaport installed)

Bob McDonald bob.tdlc at gmail.com
Mon May 21 08:28:10 UTC 2007


Looking at /etc/make.conf I don't see anything in there that looks
related in any way, and I can't think why I would have done something
like that intentionally.  Is there anything in particular I should be
on the lookout for?

thanks,

Bob

On 5/21/07, Kris Kennaway <kris at obsecurity.org> wrote:
> On Mon, May 21, 2007 at 03:08:23PM +0900, Bob McDonald wrote:
> > I just followed the instructions in UPDATING to try to upgrade xorg,
> > and recorded the script as suggested (though I didn't record the
> > portupgrade upgrade)
> >
> > On the portupgrade -Rf libXft line I ran into an error with livXau as
> > listed at the bottom of this e-mail.  (the full script is available at
> > http://www.t4ac.com/xorg-upgrade.bz2)
> >
> > I wasn't paying much attention and tried to run portupgrade -a
> > afterwards but a pkgdb problem stopped that from doping anything.
> >
> > A friend who has been reading up on the upgrade said that he saw
> > elsewhere that one should install the xorg metaport before starting,
> > but I didn't see that anywhere in UPDATING and hadn't done so.
>
> Your system still is installing into /usr/X11R6.  The only reason I
> can think of is that you have specified this in your /etc/make.conf.
> Can you confirm?
>
> Kris
>


More information about the freebsd-x11 mailing list