Error in upgrading xorg (no metaport installed)

Kris Kennaway kris at
Mon May 21 08:24:04 UTC 2007

On Mon, May 21, 2007 at 03:08:23PM +0900, Bob McDonald wrote:
> I just followed the instructions in UPDATING to try to upgrade xorg,
> and recorded the script as suggested (though I didn't record the
> portupgrade upgrade)
> On the portupgrade -Rf libXft line I ran into an error with livXau as
> listed at the bottom of this e-mail.  (the full script is available at
> I wasn't paying much attention and tried to run portupgrade -a
> afterwards but a pkgdb problem stopped that from doping anything.
> A friend who has been reading up on the upgrade said that he saw
> elsewhere that one should install the xorg metaport before starting,
> but I didn't see that anywhere in UPDATING and hadn't done so.

Your system still is installing into /usr/X11R6.  The only reason I
can think of is that you have specified this in your /etc/make.conf.
Can you confirm?


More information about the freebsd-x11 mailing list