Arch Linux UEFI Bhyve Setup

Vincent Olivier vincent at
Sun Jan 1 14:26:40 UTC 2017

Happy 2017 all,

I guess my resolution for 2017 is more clarity.

So what I mean to know with this experiment is simply this: can UEFI be used with a serial console (i.e.: without a graphic console), if so, is it preferable over GRUB for Linux distros that support UEFI?

Until I am positive about using UEFI over serial console, I will stick to GRUB but if someone coule elaborate on this, I would appreciate it greatly!



> On Dec 31, 2016, at 9:26 AM, Vincent Olivier <vincent at> wrote:
> Hi,
> A new thread for this same target setup:
> Please note that the tap interface naming doesn’t follow the nomenclature in the diagram as I am just testing isolated aspect of the setup for now.
> The « Cinq » FreeBSD 11 machine already the ALTNET non-UEFI (grub-bhyve) machine running Arch Linux. I wanted to try UEFI with the same Arch Linux distro but it doesn’t seem to work.
> Here is the grub-bhyve command sequence that I used for the Arch Linux installer on the the ALTNET virtual machine:
> zfs create -V4G -o volmode=dev bhyve/altnet
> grub-bhyve -m /bhyve/altnet/setup/ -r cd0 -M 512M altnet < /bhyve/altnet/setup/grub.cfg
> bhyve -A -H -P -s 0:0,hostbridge -s 1:0,lpc -s 2:0,virtio-net,tap0 -s3:0,virtio-blk,/dev/zvol/bhyve/altnet -s 4:0,ahci-cd,/bhyve/archlinux-2016.12.01-dual.iso -l com1,stdio -c 1 -m 512M altnet
> Here is its grub.cfg file:
> linux (cd0)/arch/boot/x86_64/vmlinuz archisobasedir=arch archisolabel=ARCH_201612 ro
> initrd (cd0)/arch/boot/x86_64/archiso.img
> boot
> Here is its file:
> (cd0) /bhyve/archlinux-2016.12.01-dual.iso
> (hd0) /dev/zvol/bhyve/altnet
> Here is my adaptation of the above for the UNIFI UEFI virtual machine, just for the Arch Linux installer:
> zfs create -V2G -o volmode=dev bhyve/unifi
> bhyve -c 1 -m 512M -A -H -P \
> 	-s 0:0,hostbridge \
> 	-s 1:0,lpc \
> 	-s 2:0,virtio-net,tap1 \
> 	-s 3:0,virtio-blk,/dev/zvol/bhyve/unifi \
> 	-s 4:0,ahci-cd,/bhyve/archlinux-2016.12.01-dual.iso \
> 	-l bootrom,/usr/local/share/uefi-firmware/BHYVE_UEFI.fd \
> 	-l com1,stdio \
> 	unifi
> But when I run this, I get this:
> Arch Linux archiso x86_64 UEFI CD
> UEFI Shell x86_64 v1
> UEFI Shell x86_64 v2
> EFI Default Loader
> Reboot Into Firmware Interface
> Boot in 1 sec.
> rdmsr to register 0x34 on vcpu 0
> Unhandled ps2 mouse command 0xe1
> Unhandled ps2 mouse command 0x0a
> Unhandled ps2 mouse command 0x01
> Unhandled ps2 mouse command 0x41
> And then it stalls. I waited max 2 minutes and then I did a "bhyvectl --destroy --vm=unifi” in another session. I tried different bhyve flags (-w, etc.) to no avail.
> Is there hope for me?
> Happy new year!
> Vincent

More information about the freebsd-virtualization mailing list