libthr/libkse and Mozilla Firebird

Daniel Eischen eischen at
Sat Sep 6 04:50:09 PDT 2003

On Sat, 6 Sep 2003, Morten Rodal wrote:

> Howdy!
> Is Mozilla Firebird (www/mozilla-firebird ; firebird-gtk2-0.6.1_1)
> supposed to work with either libthr or libkse?
> With libthr I get it to work for a little while before it deadlocks
> and I have to kill it (with SIGKILL).
> While with libkse it works, for a little while.  After starting up I
> can perhaps render half a page, sometimes a two or three pages, before
> firebird just exits.  Nothing is printed on the console and no core
> dump is found, it is as if the program just called exit(2).  I wish I
> could provide more detailed debugging, but I am having trouble getting
> firebird to run from within gdb..
> This happens on both SMP and singel processor machines.
> For the record, it _USED_ to work with libkse.  But after the ATAng
> update I was forced to upgrade my kernel a few times and now I have
> lost the date when it used to work.  Am I the only one not getting
> firebird to work?

Have you tried updating libpthread very recently (yesterday?).
There was a commit a few days ago that broke libpthread; kde
wouldn't even work.  I'm not sure if it has been fixed yet,
but there was a commit yesterday that may have fixed it.
David or kan should know...

Dan Eischen

More information about the freebsd-threads mailing list