Testing 10.1 WITH_TESTS

Garrett Cooper yaneurabeya at gmail.com
Wed Nov 26 04:33:21 UTC 2014

On Nov 25, 2014, at 20:30, Craig Rodrigues <rodrigc at FreeBSD.org> wrote:

> +freebsd-testing
> On Tue, Nov 25, 2014 at 2:14 PM, Shane Ambler <FreeBSD at shaneware.biz> wrote:
>> Test results can be found at http://shaneware.biz/kyua-tests/
> You might want to join the freebsd-testing at freebsd.org mailing list and
> report your findings there.  That list has people who are more
> actively looking at the testing framework in FreeBSD.
> From your test results:
>  (1)  The yacc tests failures are known.  Those tests are  broken in
>         10.1-RELEASE.  I fixed them in the stable/10 branch:
> https://lists.freebsd.org/pipermail/svn-src-stable/2014-October/025836.html
>  (2)  Regarding the ATF macro test failures,  I thought I fixed it with:
> https://lists.freebsd.org/pipermail/svn-src-stable/2014-September/025633.html
>         I'm not sure if that made it into 10.1-RELEASE.
>         In the stable/10 branch those are not there.
> For these tests which are failing:
>   local/kyua/testers/run_test:fork_wait__unprivileged_group

I’m not sure, but I run into this issue frequently (I haven’t filed a bug for this yet).

>   sbin/mdconfig/legacy_test:main

Probably https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=191191 (I’ll fix this tonight).

>   bin/pkill/pgrep-j_test:main

The fix you provided before doesn’t work 100% unfortunately (because there’s another bug in the base system causing this issue). I meant to bring this up sooner, but I’ve been busy (sorry :/..)

> I'm not sure why those are failing.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 496 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.freebsd.org/pipermail/freebsd-testing/attachments/20141125/62efd45b/attachment.sig>

More information about the freebsd-testing mailing list