Yubico Security Keys

Robert Ames robertames at hotmail.com
Wed Sep 5 03:13:19 UTC 2018

> > On 5 Sep 2018, at 08:33, Robert Ames <robertames at hotmail.com> wrote:
> > FreeBSD sees the device:
> >
> > Sep  4 17:25:13 freebsd kernel: ugen1.4: <Yubico Security Key by Yubico> at usbus1
> > Sep  4 17:25:13 freebsd kernel: uhid0 on uhub4
> > Sep  4 17:25:13 freebsd kernel: uhid0: <Yubico Security Key by Yubico, class 0/0, rev 2.00/5.02, addr 4> on usbus1
> >
> > So should this just work out of the box or is there something I'm
> > missing?
> Hi Robert,
> I don't have any Yubikeys but have you tried checking the permissions of /dev/uhid0* and /dev/ugen1.4 (which will be a symlink to usb/1.4.0) ?
> You can chmod them for now and then if that works have a devd conf or devfs rule which sets the permissions appropriately when the device is connected.
> If permissions are the problem it would be nice to see if the error message can be improved too :)
> --
> Daniel O'Connor

I had done a manual chmod 777 /dev/usb/1.4.0 but had overlooked /dev/uhid0.
Once I did a chmod 777 on that it worked.  Thank you.  Any suggestions on the
best way to add a devd conf or devfs rule for this thing?

More information about the freebsd-stable mailing list