Boot loader stuck after first stage upgrading 11.2-p4 to 11.2-p5

sashk b at
Sun Dec 9 02:47:49 UTC 2018


My original email was sent as html and content was stripped. Re-sending with updated information.

I recently updated my systems from 11.2-p4 to 11.2-p5 and it doesn't boot any longer. This happened on two systems, both Supermicro with X10DSC+ motherboards, and two system disks are SATA DOMs.
When booting up, it shows list of bios drives, and then spinner starts for about two-three seconds, after which it will get stuck. Waited 30 or so minutes without luck.
My understanding is that boot process freezes somewhere between first and second stage -- I'm not even getting through to the boot prompt. 

I can boot my system from FreeBSD 11.2 install disk and import zfs pool (boot disk is  mirror zfs raid). Moreover, I was able to boot system by running following commands in the boot loader when botting from FreeBSD 11.2 install CD:

set currdev=zfs:zroot/ROOT/default:
load /boot/kernel/kernel
load boot/kernel/opensolaris.ko
load boot/kernel/zfs.ko
set mrsas_enable=YES
set hw.mfi.mrsas_enable=1

After booting the system, I attempted to rollback 11.2-p5 update, and rebooted -- but got stuck at the same point. 

Then I attempted to re-write boot using gparted with gptzfsboot again -- did not help either. 

On other hand, I tried booting 12.0-rc3, but system refused to boot (using ISO mounted via IPMI) in BIOS mode, but I did not yet tried booting it in UEFI mode. I'm wondering, should I change (and can I?) my boot to UEFI? 

Any help on recovering and/or troubleshooting this will be appreciated.

More information about the freebsd-stable mailing list