amd64 kernel crash introduced between 20180329 & 20180408

Dan Allen danallen46 at
Tue Apr 17 14:45:03 UTC 2018

I run FreeBSD 11-STABLE on actual machines, and I build the system every few days.  Things have been fine.

However, I also run FreeBSD 11 via the qemu emulator on my Mac.  I run lots of different BSD & Linux OSes here to test them out.  I have been running the same binary of qemu-system-x86_64 v1.2 for six years.  It runs great.

Then recently this happened:

This snapshot dated 20180329, after doing a fresh install, runs fine:

I can run pkg install and begin adding stuff to the system and life is good.


This snapshot dated 20180408, after doing a fresh install, will crash when running pkg install:

It crashes about 90% of the way through updating the pkg snapshot.  It does not matter what pkg you try and install.

However, the latest release in the i386 flavor works fine on qemu:

So sometime between March 29th & April 8th, in amd64 boot code, I believe the problem was introduced.

I cannot debug the crash, because it does a kernel dump, and then when the system reboots, almost anything again triggers a kernel crash and it reboots again and again: no chance to inspect a mini dump or whatever.

I wish I had more to go on, but I am happy to off list work with anyone that wants to pursue this, by testing out stuff or answering more questions.

Dan Allen
Running FreeBSD since 2.2.8

More information about the freebsd-stable mailing list