problems with powerd and cpufreq on AMD Quad-Core A8-4555M

John freebsd-lists at
Mon Feb 29 01:36:16 UTC 2016

On Mon, Feb 29, 2016 at 08:29:14AM +1100, Dewayne Geraghty wrote:

>Thanks John, I have cpufreq added via the boot/loader.conf which always
>works. However, over the weekend, I was testing some boot changes and tried
>to add cpufreq AFTER the kernel - unsuccessfully.  This was amd64 10.3Beta1
>and 10.3Beta3.
>A workaround (for you) might be to remove it from the kernel and load
>cpufreq via loader.conf?
>I have some other problems (with usb nic's axge,axe) but I'll pursue if I
>get time for enough info for a PR

Hi Dewayne,

Thanks for looking at this. I modified loader.conf:

$ cat /boot/loader.conf

then recompiled the kernel and rebooted:

10.3-BETA3 #1 r296151

root at onion:~ # kldstat
Id Refs Address            Size     Name
 1   13 0xffffffff80200000 d45380   kernel
 2    1 0xffffffff80f46000 f0c8     cpufreq.ko
 3    1 0xffffffff8113d000 1604     fdescfs.ko
 4    1 0xffffffff8113f000 946      pflog.ko
 5    1 0xffffffff81140000 2d0ef    pf.ko
...but still no-go:

root at onion:~ # powerd -v
powerd: no cpufreq(4) support -- aborting: No such file or directory

Also commented out the powerd entries from /etc/rc.conf, rebooted
again, no difference.

many thanks,

More information about the freebsd-stable mailing list