[CTF] pkg 1.6.0

Baptiste Daroussin bapt at freebsd.org
Tue Sep 22 09:11:48 UTC 2015


On Tue, Sep 22, 2015 at 09:20:28AM +0200, Ranjan1018 . wrote:
> 2015-09-21 23:27 GMT+02:00 Baptiste Daroussin <bapt at freebsd.org>:
> 
> > Hi all,
> >
> > We are about to release pkg 1.6.0. pkg-devel has been updated to 1.5.99.13
> > aka
> > 1.6.0 rc3 that we hope will become the new pkg 1.6.0 btw the end of the
> > Week
> > (release planned for Saturday 26th of September or no important issues are
> > raised)
> >
> > On the list of changes:
> > - Lots of improvements in the solver (in particular fixes the case like the
> >   recent jpeg upgrade)
> > - Lots of fixes in the 3 way merge code
> > - pkg add can now work without a version specified in the dependency line
> > - pkg check -d now also check the required libraries
> > - Improved support for partial upgrades
> > - Improved zsh completion support
> > - Improved linux support (now all regression tests passes on linux)
> > - Messages can now be context aware: (only print a given message during
> >   installation, upgrade - version aware -, removal, or always)
> > - @keywords now accepts new entries to add context aware messages
> > - Add the ability to generate graphiz's dot format representation of the
> >   solver's problem
> > - pkg search now default on showing the comments of of the matched packages
> > - Lots of bug fixes and code cleanup
> > - Plenty of new bugs
> >
> > Please test heavily, I would like to make a release quite soon to limit the
> > number of users suffering from the jpeg->jpeg-turbo update.
> >
> > Best regards,
> > Bapt
> >
> 
> Thank you Batp,
> 
> running version 1.5.3 I have this error message:
> # pkg upgrade
> Updating FreeBSD repository catalogue...
> FreeBSD repository is up-to-date.
> All repositories are up-to-date.
> Checking for upgrades (40 candidates): 100%
> Processing candidates (40 candidates): 100%
> Checking integrity... done (1 conflicting)
> pkg: Cannot solve problem using SAT solver:
> dependency rule: package Thunar(l) depends on:
> xfce4-tumbler(r)xfce4-tumbler(l)
> upgrade rule: upgrade local xfce4-tumbler-0.1.31_1 to remote
> xfce4-tumbler-0.1.31_1
> cannot install package xfce4-tumbler, remove it from request? [Y/n]:
> pkg: cannot find xfce4-tumbler in the request
> pkg: cannot solve job using SAT solver
> Checking integrity... done (0 conflicting)
> Your packages are up to date.
> 
> With this version I have been able to update the packages.
> 
Thanks for the test!

Best regards,
Bapt
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: not available
URL: <http://lists.freebsd.org/pipermail/freebsd-stable/attachments/20150922/5b691562/attachment.bin>


More information about the freebsd-stable mailing list