System hang on shutdown when running freebsd-update

Kevin Oberman rkoberman at
Tue Oct 14 17:09:24 UTC 2014

I thought that this was just a fluke, but it has now happened three times,
so I guess it's now out of the "fluke" class.

I have upgraded several times recently to each 10.1 BETA and RC. After the
first install pass t install the kernel and modules, the system shutdown
freezes at the very end. I see the buffers synced to the disks and get the
"All buffers synced" message. Then it just hangs. The disks are not marked
as clean and are fscked after a reset and boot.

There is not much between the "All buffers synced" message and the call to
vfs_unmountall(), so I suspect it is hanging in that call. I admit that I
am pretty much lost whenever I look at the VFS code and I have not put a
lot of effort going further. Just hoping that someone familiar with it
might have an idea.

I have tried several reboots and all run normally. The problem only seems
to appear when upgrading the OS. It happened repeatedly when I tried to
reboot before doing the second "install" pass of freebsd-update, but not
after, so the kernel and world are not in sync. I am baffled as to what
could be going on, but it means I need to be at the system (a baby server)
when I upgrade, but not every time I upgrade. I know it happened on the
10.0-RELEAASE to 10.1-BETA1 and 10.1-RC1 to 10.1-RC2 upgrades.

Has anyone else seen this?

The system is an Asus VivoPC VM40B-2.
CPU: Intel(R) Celeron(R) CPU 1007U @ 1.50GHz (1496.63-MHz K8-class CPU)
  Origin = "GenuineIntel"  Id = 0x306a9  Family = 0x6  Model = 0x3a
Stepping =9


  AMD Features=0x28100800<SYSCALL,NX,RDTSCP,LM>
  AMD Features2=0x1<LAHF>
  Structured Extended Features=0x281<FSGSBASE,SMEP,ERMS>
  TSC: P-state invariant, performance statistics
real memory  = 4294967296 (4096 MB)
avail memory = 4014346240 (3828 MB)

R. Kevin Oberman, Network Engineer, Retired
E-mail: rkoberman at

More information about the freebsd-stable mailing list