9.1 RELENG_9 Unable to cleanly dismount root partition on shutdown

Warren Block wblock at wonkity.com
Mon Aug 27 13:56:18 UTC 2012

On Mon, 27 Aug 2012, Matt Smith wrote:

> On 2012-08-27 11:26, Erich Dollansky wrote:
>> I would run plain UFS for / /var and /tmp and see what will happen then.
>> I know what you will answer. But it will help to isolate the problem.
> Did you mean not use the label at all? If so I just tried this. Set 
> /dev/ada0p2 in the fstab. No change. Still get the same issue.
> This might help investigations as I wrote down what I did to install it.
> The way I created this filesystem was that I dropped out of the installer to 
> a shell because I wanted to do the 4k alignment. And I ran this:
> gpart create -s gpt ada0
> gpart add -t freebsd-boot -l gptboot -s 512k ada0
> gpart bootcode -b /boot/pmbr -p /boot/gptboot -i 1 ada0
> gpart add -t freebsd-ufs -l gptroot -b 1M -s 586G ada0
> gpart add -t freebsd-swap -l gptswap ada0
> gpart show
> =>        34  1250263661  ada0  GPT  (596G)
>          34        1024     1  freebsd-boot  (512k)
>        1058         990        - free -  (495k)
>        2048  1228931072     2  freebsd-ufs  (586G)
>  1228933120    21330575     3  freebsd-swap  (10G)
> newfs -U -j -L root /dev/gpt/gptroot
> glabel label root /dev/ada0p2
> glabel label swap /dev/ada0p3
> mount /dev/gpt/gptroot /mnt
> vi /tmp/bsdinstall_etc/fstab
> # Device                Mountpoint      FStype  Options         Dump    Pass#
> /dev/label/root         /               ufs     rw              1       1
> /dev/label/swap         none            swap    sw              0       0

Stefan called it.  The newfs is done on /dev/gpt/gptroot, no problem 
there.  But when glabel writes to /dev/ada0p2--which is 
/dev/gpt/gptroot, same thing, it overwrites the last block.  And then 
the filesystem is mounted with the glabel device, which is actually one 
block smaller than the filesystem expects.

Could be either the filesystem or GEOM that's causing the failure at 

Happily, those glabels aren't accomplishing anything useful and can be 
skipped.  Removing the glabels and changing the devices in fstab might 
be enough.  A more cautious approach would be to back up, newfs, skip 
the glabel step, and then change the devices in fstab.

More information about the freebsd-stable mailing list