9.1 RELENG_9 Unable to cleanly dismount root partition on shutdown

Matt Smith matt at xtaz.co.uk
Mon Aug 27 10:40:49 UTC 2012

On 2012-08-27 11:26, Erich Dollansky wrote:
> I would run plain UFS for / /var and /tmp and see what will happen 
> then.
> I know what you will answer. But it will help to isolate the problem.

Did you mean not use the label at all? If so I just tried this. Set 
/dev/ada0p2 in the fstab. No change. Still get the same issue.

This might help investigations as I wrote down what I did to install 

The way I created this filesystem was that I dropped out of the 
installer to a shell because I wanted to do the 4k alignment. And I ran 

gpart create -s gpt ada0
gpart add -t freebsd-boot -l gptboot -s 512k ada0
gpart bootcode -b /boot/pmbr -p /boot/gptboot -i 1 ada0
gpart add -t freebsd-ufs -l gptroot -b 1M -s 586G ada0
gpart add -t freebsd-swap -l gptswap ada0
gpart show

=>        34  1250263661  ada0  GPT  (596G)
           34        1024     1  freebsd-boot  (512k)
         1058         990        - free -  (495k)
         2048  1228931072     2  freebsd-ufs  (586G)
   1228933120    21330575     3  freebsd-swap  (10G)

newfs -U -j -L root /dev/gpt/gptroot
glabel label root /dev/ada0p2
glabel label swap /dev/ada0p3
mount /dev/gpt/gptroot /mnt
vi /tmp/bsdinstall_etc/fstab

# Device                Mountpoint      FStype  Options         Dump    
/dev/label/root         /               ufs     rw              1       
/dev/label/swap         none            swap    sw              0       


More information about the freebsd-stable mailing list