9.1 RELENG_9 Unable to cleanly dismount root partition on shutdown

Matt Smith matt at xtaz.co.uk
Mon Aug 27 10:12:54 UTC 2012

On 2012-08-27 10:28, Stefan Bethke wrote:
> Is there a particular reason you've decided to glabel your partitions
> instead of using GPT labels? Which device did you do the newfs on, 
> the
> GPT partition or the glabel device?  My hunch is that the label
> metadata sector at the end of the GPT partition is interfering with
> the filesystem.
> I'd try labelling my partitions (gpart modify -i 2 -l root ada0;
> gpart modify -i 3 -l swap), then change fstab to reference the gpt
> labels (dev(gpt/root) instead of the glabel ones.

No reason at all really. I had just used it like that on a previous MBR 
based system and it worked fine. I have just booted it using the USB 
stick again and removed both labels metadata using glabel stop and clear 
and changed the fstab to use /dev/gpt/ labels now. Unfortunately the 
same issue persists. It mounted fine, but when I rebooted it it synced 
all buffers successfully but then gave the same error saying that it 
couldn't unmount /.

More information about the freebsd-stable mailing list