Gpart and gmirror 8.2 from 18 januari

Johan Hendriks Johan at
Fri Jan 21 12:56:11 UTC 2011

Ok the funny thing is, i get the same error on 8.1 Release (the corrupt error), but it boots, and all seems to work.
But i will try the option by First create the mirror and the the gpt partitions.


-----Oorspronkelijk bericht-----
Van: owner-freebsd-stable at [mailto:owner-freebsd-stable at] Namens Ivan Voras
Verzonden: vrijdag 21 januari 2011 12:19
Aan: freebsd-stable at
Onderwerp: Re: Gpart and gmirror 8.2 from 18 januari

On 19/01/2011 12:30, Johan Hendriks wrote:
> Hello all, i used to have disk configured with gpart and gmirror.
> But with the latest 8.2, my server will not boot anymore if i label the
> disk with gmirror.
> Gpart status
> Name  Status  Components
> ad4p1      OK  ad4

> Then i do a gmirror label -v -b load gm0 /dev/ad4
> Edit /etc/fstab
> And change /dev/ad4px to /dev/mirror/gm0px
> I reboot, and it hangs when tring to Mount the root device.
> I get an error about an corrupt gpt label.

Yes, GPT has the unfortunate property that it records its data both at 
the beginning of a drive and at the end, so you cannot use it this way 
(because gmirror wants the last sector for itself).

I haven't tried it but I think from the GPT specification that it 
records where the secondary table is, so maybe you could do it the other 
way around: first do a gmirror configuration, then create GPT partitions 
within the gmirror device (i.e. on /dev/mirror/gm0, not on /dev/ad4).

freebsd-stable at mailing list
To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"

More information about the freebsd-stable mailing list