New ZFSv28 patchset for 8-STABLE

Attila Nagy bra at
Mon Jan 10 17:23:49 UTC 2011

  On 01/10/2011 10:02 AM, Pawel Jakub Dawidek wrote:
> On Sun, Jan 09, 2011 at 12:49:27PM +0100, Attila Nagy wrote:
>> No, it's not related. One of the disks in the RAIDZ2 pool went bad:
>> (da4:arcmsr0:0:4:0): READ(6). CDB: 8 0 2 10 10 0
>> (da4:arcmsr0:0:4:0): CAM status: SCSI Status Error
>> (da4:arcmsr0:0:4:0): SCSI status: Check Condition
>> (da4:arcmsr0:0:4:0): SCSI sense: MEDIUM ERROR asc:11,0 (Unrecovered read
>> error)
>> and it seems it froze the whole zpool. Removing the disk by hand solved
>> the problem.
>> I've seen this previously on other machines with ciss.
>> I wonder why ZFS didn't throw it out of the pool.
> Such hangs happen when I/O never returns. ZFS doesn't timeout I/O
> requests on its own, this is driver's responsibility. It is still
> strange that the driver didn't pass I/O error up to ZFS or it might as
> well be ZFS bug, but I don't think so.
Indeed, it may to be a controller/driver bug. The newly released (last 
december) firmware says something about a similar problem. I've 
upgraded, we'll see whether it will help next time a drive goes awry.
I've only seen these errors in dmesg, not in zpool status, there 
everything was clear (all zeroes).

BTW, I've swapped those bad drives (da4, which reported the above 
errors, and da16, which didn't reported anything to the OS, it was just 
plain bad according to the controller firmware -and after its deletion, 
I could offline da4, so it seems it's the real cause, see my previous 
e-mail), and zpool replaced first da4, but after some seconds of 
thinking all IO on all disks deceased.
After waiting some minutes, it was still the same, so I've rebooted. 
Then I noticed that a scrub is going on, so I stopped it.
Then the zpool replace da4 went fine, it started to resilver the disk. 
But another zpool replace (for da16) causes the same error: some seconds 
of IO, then nothing and it stuck in that.

Has anybody tried replacing two drives simultaneously with the zfs v28 
patch? (this is a stripe of two raidz2s and da4 and da16 are in 
different raidz2)

More information about the freebsd-stable mailing list