NFS - DNS fail stops boot in mountlate

John Baldwin jhb at
Fri Jan 7 16:08:00 UTC 2011

On Friday, January 07, 2011 10:29:22 am Julian H. Stacey wrote:
> > I've seen a regression in 8 at work where NFS mounts seem to fail on DNS on 
> > every boot (we have a small number of mounts, < 10) whereas 7 worked fine on 
> > every boot.  I haven't tracked it down yet, but 8 is certainly more fragile 
> > than 7 for mounting NFS on boot.
> /etc/defaults/rc.conf has	nfs_server_flags="-u -t -n 4"
> Once I had a server with example	 /etc/rc.conf -n 10 
> & had problems when I added partions beyond eg 10 ...
> so I suggest check rc.conf against fstab & /etc/exports

That should not matter for establishing mounts.  Also, keep in mind that 7
worked fine with the same settings.  In fact, I'm just booting an 8 kernel
on the same 7 userland currently and it's only the 8 kernel that has the
problem (a pure 8 system also has the same symptoms, so it's not a problem
due to mixing a 7 world with 8 kernel).

John Baldwin

More information about the freebsd-stable mailing list