bridge, ipv6 and rtadvd

Stefan Bethke stb at
Sun Feb 6 14:14:32 UTC 2011

Am 06.02.2011 um 13:23 schrieb Spil Oss:

> Hi All,
> Don't know if this is expected behaviour.
> My LAN (bge0) and WLAN (wlan0) are bridged in bridge0. I tried to run
> rtadvd on bridge0 but that didn't result in ipv6 addresses on my
> network. Tried running rtadvd directly /usr/sbin/rtadvd -c
> /etc/rtadvd.conf -f -D and saw the requests coming in from the client
> but that didn't result in a working ipv6 network. "Wild guessing" I
> tried loading it with /usr/sbin/rtadvd -f -D bge0 and I had a
> functional ipv6 network.....
> Is this intended behaviour? Am I doing something wrong?

It appears to be intentional; there was some discussion a couple years back, and the current behavior is for virtual interfaces to not receive link-local addresses.

Since I prefer to have bridge0 as the "main" interface, I simply manually configured a link local address:

ipv6_network_interfaces="bridge0 gif0"
ipv6_ifconfig_bridge0_alias0="2001:470:1f0b:XXXX::1 prefixlen 64"
ipv6_ifconfig_gif0="2001:470:1f0a:XXXX::2 2001:470:1f0a:XXXX::1 prefixlen 128"

$ cat /etc/rtadvd.conf 

The IPv4 side of gif0 is brought up through a linkup script triggered by mpd when my DSL connection comes up; that also updates the endpoint address for the HE tunnel.

Oh, this is on -stable from Dec 4.


Stefan Bethke <stb at>   Fon +49 151 14070811

More information about the freebsd-stable mailing list