7.0-stable: a hung process - scheduler bug?

Mikhail Teterin mi+mill at aldan.algebra.com
Tue Sep 23 19:56:46 UTC 2008

Josh Carroll написав(ла):
>> However, what I'm seeing on my system today is evidence of the scheduler
>> having a bug, rather than merely being suboptimal. If the old scheduler is
>> still maintained and supposed to work (however sub-optimally) in 4-CPU
>> configurations, I'd expect either inquiries for more debug-information or
>> assurances, that the bug is known and worked on.
> I'm no expert, but I don't think you can necessarily conclude that it
> is the scheduler yet. It very well may be, but I agree that someone
> with more expertise hopefully will ask for more detailed debug/trace
> information to pin down where the problem lies.
Although the machine seemed fine, it would not launch new processes ever 
since I tried to start `systat 1 -vm' -- something systat does at 
start-up must've wedged the system...
A process, that was running (cvs over ssh) is currently stuck (according 
to Ctrl-T) in:

    load: 0.00  cmd: ssh 59098 [proctree] 0.41u 0.17s 0% 0k

I'll reboot it, when I get back home...


More information about the freebsd-stable mailing list