freebsd 7 with sata drives

Jeremy Chadwick koitsu at
Sun Sep 21 13:51:15 UTC 2008

On Sat, Sep 20, 2008 at 10:30:43PM -0700, Brian wrote:
> Brian wrote:
>> The board in question is an Asus M3A78-EMH HDMI.  I have tried the  
>> instructions for a safe kernel compile in /usr/src/updating also.   
>> Even after that, the kernel starts to load, but the root partition  
>> cant be found, and I am left at a mountroot> prompt.  If I go  
>> ufs:ad5s1a, that fails as well.
>> Brian
> I have done much more testing on this.  With a pata drive all is well.   
> I can install 7.0-release and run freebsd-update successfully including  
> the subsequent reboots.  However, over the weekend I tried to go to  
> stable again, and still, the subsequent reboot leaves me at a mountroot  
> prompt.  If I go ufs:ad8s1a  at the prompt the root partition, of course  
> I dont want to have to do this each time.  If I use the september  
> snapshot, the sata disk is visible.  I just tried to run and iinstall a  
> 6.4 prerelease, and then did a make buildworld && make kernel  
> KERNCONF=SMP and that worked successfully.  I see this behavior with a  
> 160 gig wd disk as well as a 74 gig raptor(This weekend's test hardware).

Others are having this problem, though not prompted with a mountroot>
prompt (others are experiencing a hard system lock-up after the "Mount
root from ufs..." message.  I doubt the problem is you.

| Jeremy Chadwick                                jdc at |
| Parodius Networking              |
| UNIX Systems Administrator                  Mountain View, CA, USA |
| Making life hard for others since 1977.              PGP: 4BD6C0CB |

More information about the freebsd-stable mailing list