RELENG_7 nvidia xorg hard lock

Marian Hettwer mh at
Mon Sep 15 07:56:12 UTC 2008

>> Reply to myself:
>> it seems, that the nvidia card isn't recognized by the nvidia kld.
>> xorg.log states:
>> (EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please
>> ensure
>> (EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system,
>> and
>> (EE) NVIDIA(0):     that the NVIDIA device files have been created
>> properly.
>> (EE) NVIDIA(0):     Please consult the NVIDIA README for details.
>> (EE) NVIDIA(0):  *** Aborting ***
>> Wh00t? This card worked before...
>> nvidia0: <Unknown> on vgapci0
>> vgapci0: child nvidia0 requested pci_enable_busmaster
>> vgapci0: child nvidia0 requested pci_enable_io
>> nvidia0: [GIANT-LOCKED]
>> nvidia0: [ITHREAD]
>> Something is odd here...
> Obviously Xorg has nothing to do with this issue.
You are right on that point.

> Please make sure that your nvidia module is up-to-date and in sync with
> current kernel.
It is. I double checked that.

> If I were you, I would delete nvidia-driver package, make sure that it
> gone from /boot/modules, than download latest driver version
> and recompile it. After that try to reboot and see what happens.
That's what I actually did. "make deinstall" the nvidia-driver, checked
/boot/modules and recompiled the driver.
Afterwards reboot, since the pkg-message states, users of 7.X and above
shouldn't use kldload but loader.conf instead (why's that by the way???).

Still no luck.
The card doesn't get recognized.
And it used to work, as I wrote in my initial mail.

I even plugged the card into a different box to verify that the hardware is
It is!

best regards,

More information about the freebsd-stable mailing list