LevelOne WPC-0301 11g Wireless CardBus

Oliver Fromme olli at lurza.secnetix.de
Fri Oct 31 15:03:21 PDT 2008

Jan Henrik Sylvester wrote:
 > Oliver wrote:
 > > I bought a LevelOne WPC-0301 11g Wireless CardBus Adapter
 > > today.  According to the box it is "v6".  The ral(4) man-
 > > page mentions only v2, but that one is ancient and can't
 > > be bought anymore.
 > I do not know about the WPC-0301, but I since I bought a wrong WNC-0301 
 > (PCI version), I did some research looking at the IDs and additionally 
 > Windows drivers: v.1 is Marvel, v.2 is the old Ralink, v.3 is the never 
 > Ralink, and v.5  (and v.6?) is RealTek. (v.4 does not have a Windows 
 > driver at the LevelOne homepage.)
 > BTW: I did summit this info to http://linux-wless.passys.nl/ -- it is a 
 > pretty good overview, especially if you want to check which vendors 
 > switch chipset manufacturers from one revision to the next.
 > My guess would be that you are out of luck, if it is not detected at 
 > 7-STABLE. Look at the sys files in the Windows driver, if there is one. 
 > Of course, you can try ndis, but I would not go for it.
 > If you shop for a card, most of the 108Mbps are Atheros, which works 
 > better than Ralink in my experience. Since you are from Germany, too: 
 > geizhals.at lists TP-Link TL-WN610G for less than 15 Euros, which has an 
 > Atheros chipset according to the site I mentioned above. If you are 
 > looking on Ebay, I can really recommend Philips SNN6500, which does 
 > a/b/g and the proprietary Atheros stuff (TURBOP, BURST).

Thank you for the comments and the URL!

Fortunately, the guy at the shop (*) took the card back
without asking any questions and replaced it with an
Atheros-based 108Mbps card (LeveOne WPC-0300).

This card seems to work.  I haven't tried to connect to
an actual AP yet (will do that on my next trip), but at
least the card is detected when plugged in and attaches
as ath0, and "list scan" returns some output (probably
the APs from neighbors).

However, a simple "ifconfig ath0 scan" never terninates.
I have to press ^C.  Is this normal?

Also, my X session froze after the card was plugged in
for about 20 minutes (but it was not in use, i.e. not
connected to an AP).  Removing the card solved it.
I hope this was just an accidental hiccup.

Best regards

(*)  For anybody near Munich, I can recommend the shop
"NB Computer" (Schillerstr. near Hbf).  Friendly people
and good prices.  (I'm not in any way associated with
them nor benefit from recommending them.  Just a happy

Oliver Fromme, secnetix GmbH & Co. KG, Marktplatz 29, 85567 Grafing b. M.
Handelsregister: Registergericht Muenchen, HRA 74606,  Geschäftsfuehrung:
secnetix Verwaltungsgesellsch. mbH, Handelsregister: Registergericht Mün-
chen, HRB 125758,  Geschäftsführer: Maik Bachmann, Olaf Erb, Ralf Gebhart

FreeBSD-Dienstleistungen, -Produkte und mehr:  http://www.secnetix.de/bsd

"FreeBSD is Yoda, Linux is Luke Skywalker"
        -- Daniel C. Sobral

More information about the freebsd-stable mailing list