dmesg : no output on 1 of 2 7-stable boxes

Julian H. Stacey jhs at
Sat Jan 26 07:39:53 PST 2008

One of 2 laptops running 7-stable shows nothing with dmesg, (other is OK).
Needs fresh eyes please, as I've already checked all this:
   - Text is in /var/log/messages, readable to normal users.
   - df shows enough disc
   - I patched out all of loader.conf, except essential hw.ata.ata_dma="0"
   	(that was to remove any *verbose* that might be overflowing
   - I tried loader.conf 	kern.msgbuf=64000	
   - Tried a Generic kernel
   - I've recompiled & installed dmesg & kernels
   - Haven't done a make world (slow box), but repeated make all ; make install
     with each day's new source.
   - Both hosts running same /usr/src from yesterday:
           Jan 25 15:25 TZ=GMT+01:00
   - cd /etc;grep dmesg *
   	rc.conf:dmesg_enable="YES"      # Save dmesg(8) to /var/run/dmesg.boot
   	Binary file rc.d matches	# Just the standard /etc/rc.d/dmesg
   	rc.local:/sbin/dmesg > /tmp/dmesg.rc.local
   	# -rw-r--r--  1 root  wheel  0 Jan 25 14:01 /tmp/dmesg.rc.local
   - mergemaster -sicvP 
Any ideas please ?
Julian Stacey.  Munich Consultant: BSD Linux Unix.

More information about the freebsd-stable mailing list