System hangs up every day

A. Rymkus rymkus at
Mon Jan 21 20:15:16 PST 2008

Hello Дмитрий,

Tuesday, December 18, 2007, 11:42:19 AM, you wrote:

ДК> Hello everybody

ДК> Unfortunately my problem still doesn't have any solution.
ДК> But I have an interesting observation. The gateway freezes very
ДК> quickly, if torrent client programs are running on workstations.
ДК> I assume the cause of the problem consists in many number of
ДК> TCP/IP connections that torrent client establishes.
ДК> Any ideas?
ДК> Maybe I can tune somehow a TCP/IP via kernel, sysctl or pf settings?

>> There is one FreeBSD server in our company. The server platform is: Supermicro SuperServer 6014V-T2B (2x Intel > Xeon 2.8, 1Gb RAM, 3WARE 3W-8006-2LP RAID-Controller).
>> The server works as:
>> - a gateway between LAN and Internet
>> - an Intranet web- and database server (Apache + MySQL + PHP)
>> - a firewall (OpenBSD pf)
>> - a transparent proxy server (Squid)
>> A mounthly traffic through this server is about 100Gb. There is about 200 internet users in our conpany.
>> FreeBSD 6.2-RELEASE-p8

>> This server hangs up every day without any messages in the log files and on the system console. A keyboard dosen't work too. I can make only hard reset and after restart coredump files are not appearing.

>> If I make and install a kernel with SMP options the system under working load begins hang up every two hours.

>> The two days "Memtest" gave no result.
>> I tried to install the newest Intel ethernet adapter driver, but without any results.
>> As an experiment I tried also to plug a system HDD to another sever platform (SuperServer 6015V-TB), but system hanging didn't stop.
>> I think that it is not only hardware problem.
>> Linux (Gentoo) and Windows server 2003 on this hardware were working fine.

ДК> _______________________________________________
ДК> freebsd-stable at mailing list
ДК> To unsubscribe, send any mail to
ДК> "freebsd-stable-unsubscribe at"

  Got same problem in 6.2 based on VMWare ESX 3.0, with both type of
provided adapters type - lnc & em. System just hangs one adapter first, then hangs completely.
  Can this problem be solved by cvsup'g and rebuilding whole world, or
I have to wait for 7.0-RELEASE? ;)

DMESG ---------------------------------
Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.3-PRERELEASE #0: Sat Jan 19 22:09:31 MSK 2008
    root at
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(R) CPU            5120  @ 1.86GHz (1863.30-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x6f8  Stepping = 8
  AMD Features=0x20100000<NX,LM>
  AMD Features2=0x1<LAHF>
real memory  = 536870912 (512 MB)
avail memory = 515739648 (491 MB)
ACPI APIC Table: <PTLTD          APIC  >
MADT: Forcing active-low polarity and level trigger for SCI
ioapic0 <Version 1.1> irqs 0-23 on motherboard
acpi0: <PTLTD   RSDT> on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-safe" frequency 3579545 Hz quality 850
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
isab0: <PCI-ISA bridge> at device 7.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel PIIX4 UDMA33 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1050-0x105f at device 7.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
pci0: <bridge> at device 7.3 (no driver attached)
pci0: <display, VGA> at device 15.0 (no driver attached)
mpt0: <LSILogic 1030 Ultra4 Adapter> port 0x1080-0x10ff mem 0xf4830000-0xf4830fff irq 17 at device 16.0 on pci0
mpt0: MPI Version=
em0: <Intel(R) PRO/1000 Network Connection Version - 6.7.2> port 0x1070-0x1077 mem 0xf4840000-0xf485ffff,0xf4800000-0xf480ffff irq 18 at device 17.0 on pci0
em0: Memory Access and/or Bus Master bits were not set!
em0: Ethernet address: 00:0c:29:5e:f5:02
em1: <Intel(R) PRO/1000 Network Connection Version - 6.7.2> port 0x1078-0x107f mem 0xf4860000-0xf487ffff,0xf4810000-0xf481ffff irq 19 at device 18.0 on pci0
em1: Memory Access and/or Bus Master bits were not set!
em1: Ethernet address: 00:0c:29:5e:f5:0c
em2: <Intel(R) PRO/1000 Network Connection Version - 6.7.2> port 0x1400-0x1407 mem 0xf4880000-0xf489ffff,0xf4820000-0xf482ffff irq 16 at device 19.0 on pci0
em2: Memory Access and/or Bus Master bits were not set!
em2: Ethernet address: 00:0c:29:5e:f5:16
acpi_acad0: <AC Adapter> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
ppc0: <Standard parallel printer port> port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: <Parallel port bus> on ppc0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xca000-0xcafff,0xcb000-0xcbfff,0xcc000-0xccfff,0xdc000-0xdffff,0xe0000-0xe3fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1863302658 Hz quality 800
Timecounters tick every 1.000 msec
ipfw2 initialized, divert enabled, rule-based forwarding enabled, default to deny, logging disabled
Waiting 5 seconds for SCSI devices to settle
da0 at mpt0 bus 0 target 0 lun 0
da0: <VMware Virtual disk 1.0> Fixed Direct Access SCSI-2 device
da0: 80.000MB/s transfers (40.000MHz, offset 127, 16bit), Tagged Queueing Enabled
da0: 20480MB (41943040 512 byte sectors: 255H 63S/T 2610C)
Trying to mount root from ufs:/dev/da0s1a
DMESG ---------------------------------

(03:59:22 <~>) 0 # pciconf -lv
hostb0 at pci0:0:0:        class=0x060000 card=0x197615ad chip=0x71908086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82443BX/ZX 440BX/ZX CPU to PCI Bridge (AGP Implemented)'
    class      = bridge
    subclass   = HOST-PCI
pcib1 at pci0:1:0: class=0x060400 card=0x00000000 chip=0x71918086 rev=0x01 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82443BX/ZX 440BX/ZX AGPset PCI-to-PCI bridge'
    class      = bridge
    subclass   = PCI-PCI
isab0 at pci0:7:0: class=0x060100 card=0x197615ad chip=0x71108086 rev=0x08 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82371AB/EB/MB PIIX4/4E/4M ISA Bridge'
    class      = bridge
    subclass   = PCI-ISA
atapci0 at pci0:7:1:       class=0x01018a card=0x197615ad chip=0x71118086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82371AB/EB/MB PIIX4/4E/4M IDE Controller'
    class      = mass storage
    subclass   = ATA
none0 at pci0:7:3: class=0x068000 card=0x197615ad chip=0x71138086 rev=0x08 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82371AB/EB/MB PIIX4/4E/4M Power Management Controller'
    class      = bridge
none1 at pci0:15:0:        class=0x030000 card=0x040515ad chip=0x040515ad rev=0x00 hdr=0x00
    vendor     = 'VMware Inc.'
    device     = 'VGA 4.0.5 Virtual SVGA'
    class      = display
    subclass   = VGA
mpt0 at pci0:16:0: class=0x010000 card=0x00000000 chip=0x00301000 rev=0x01 hdr=0x00
    vendor     = 'LSI Logic (Was: Symbios Logic, NCR)'
    device     = 'LSI53C1020/1030 PCI-X to Ultra320 SCSI Controller'
    class      = mass storage
    subclass   = SCSI
em0 at pci0:17:0:  class=0x020000 card=0x075015ad chip=0x100f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82545EM Gigabit Ethernet Controller (copper)'
    class      = network
    subclass   = ethernet
em1 at pci0:18:0:  class=0x020000 card=0x075015ad chip=0x100f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82545EM Gigabit Ethernet Controller (copper)'
    class      = network
    subclass   = ethernet
em2 at pci0:19:0:  class=0x020000 card=0x075015ad chip=0x100f8086 rev=0x01 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82545EM Gigabit Ethernet Controller (copper)'
    class      = network
    subclass   = ethernet

Best regards,
 A.                            mailto:rymkus at

More information about the freebsd-stable mailing list