WARNING: 7-STABLE BROKEN -- please wait to upgrade

Alex Goncharov alex-goncharov at comcast.net
Sun Aug 31 14:43:24 UTC 2008

Still having problems...

,--- I/Alex (Wed, 27 Aug 2008 20:42:00 -0400) ----*
| ,--- You/Kostik (Wed, 27 Aug 2008 19:04:32 +0300) ----*
| | cd into /usr/src/gnu/usr.bin/cc/cc1,
| | 	make install DEBUG_FLAGS=-g
| That simple thing didn't work for me:

| But I've found what may be an extremely easy way out of this hole: I
| copied over /usr/libexec/cc1 from another machine, which had a code
| built on Aug 17.  Then my `cc1' worked fine and I tripped on a SEGV in
| `as'.  Then I copied over `as', then `ld', then `gcc'.  And that was
| it -- the build began to work.

I have been happily using the four replacement tools to build various
user-land programs.  Then yesterday I decided to try to update the OS.
The build finished successfully (or so it seemed), I rebooted,
installed world, and now I have the same issue as everybody else had
this week:

  cc: Internal error: Abort trap: 6 (program cc1)

  $ ls -l /usr/libexec/cc1
  -r-xr-xr-x  1 root  wheel  5435068 Aug 31 09:03 /usr/libexec/cc1*

  $ uname -svr
  FreeBSD 7.1-PRERELEASE FreeBSD 7.1-PRERELEASE #36: Sun Aug 31
  00:08:48 EDT 2008

I am going to replace the four cc components again, with the old and
tried ones, and update/build again, but this doesn't feel right.

Is there anything else I should have done to avoid these problems? 

Is everything supposed to work out of box now?


-- Alex -- alex-goncharov at comcast.net --

 * Progress was all right.  Only it went on too long.
 * -- James Thurber

More information about the freebsd-stable mailing list