IPMI Console: No luck once OS is booted

David Duchscher daved at tamu.edu
Sun Aug 10 15:25:20 UTC 2008

On Aug 10, 2008, at 8:24 AM, Larry Rosenman wrote:

> On Sat, 9 Aug 2008, Larry Rosenman wrote:
>> On Sat, 9 Aug 2008, Larry Rosenman wrote:
>>> I have a current RELENG_7 running on: http://www.supermicro.com/products/system/4U/7045/SYS-7045B-TR+.cfm
>>> with the -3+ IPMI card.
>>> I can interact with the BIOS, etc, but no joy once we get past the  
>>> loader.
>>> Anyone have ideas?
>>> Attached is the kernel config, and the /var/run/dmesg.boot file.
>> I hate it when I post something, and then look at one setting on the
>> card, and fix it myself.
>> There is a key release timeout checkbox on the keyboard/mouse
>> settings tab for the KVM that wasn't checked.  Checking it
>> fixed it.
>> Sorry for the noise. :(
> Actually, it worked *ONCE*, and now is not behaving itself.
> Any ideas from other SuperMicro users?

I don't have that IPMI card but I can say we have other cards of  
theirs working.  I would make sure the card is at the latest version  
of firmware.  The AOC-SIMSO(+) card was not detected correctly until  
we upgraded.  I don't know why the card is going away when freebsd  
boots since I assume you are on the dedicated LAN interface with its  
own IP address.

We do have a few issues with Supermiro IPMI and FreeBSD that share the  
Intel NIC (em) with the OS.  Once the NIC is detected, you can't talk  
to the IPMI card until the NIC is configured with ifconfig.  Even just  
an ifconfig up will wake things back up.  We ended up removing the em  
driver from the kernel and loading it as a module to reduce this window.

The other issue is with bridging since the IPMI packets get gobbled up  
and never make it too the bridge.

I do need to file PRs for these one of these days...

More information about the freebsd-stable mailing list