USB keyboard locking up on 7-RELEASE/amd64

Alexandre "Sunny" Kovalenko gaijin.k at
Thu Apr 10 23:46:49 UTC 2008

On Wed, 2008-04-09 at 17:07 -0500, H. Wade Minter wrote:
> I have a Dell Optiplex 755, with an Intel Core 2 Duo chip.  I have  
> installed 7-RELEASE/amd64 on it.  2GB of RAM, 6GB of swap.
> The install went fine, but post-install I'm running into a problem  
> where the USB keyboard will just lock up.  I can still ping and SSH  
> into the system, but after about 2 minutes of activity, the keyboard  
> becomes nonresponsive.
> I can move the USB plug to a different port, and see that it's  
> recognize, and the keyboard comes back, but a couple of minutes later,  
> it locks again.
> I've checked with things in the BIOS, but can't find any setting that  
> makes a difference.  I've tried both the 4BSD and ULE scheduler, no  
> changes.
> Any thoughts or known issues that would explain this?  When the lockup  
> happens, there's nothing in /var/log/messages or dmesg to indicate a  
> problem.
> The only other clues are that sometimes, right before it locks, it  
> will go into a repeat loop on a keypress, and it seems to be able to  
> be reliably triggered by switching virtual consoles (though not  
> exclusively).
> I've tried different keyboards, so it doesn't appear to be a hardware  
> issue.
I have seen this happening with OptiPlex 740 and OpenSuSE 10.3. Updating
the BIOS on the OptiPlex fixed the problem. In my case, I was able to
find reports of this behavior on the Dell's Linux forums, so it
certainly was not limited to my specimen. I do realize that your machine
is different, so YMMV.

> Thoughts?
> --Wade
> _______________________________________________
> freebsd-stable at mailing list
> To unsubscribe, send any mail to "freebsd-stable-unsubscribe at"
Alexandre "Sunny" Kovalenko (Олександр Коваленко)

More information about the freebsd-stable mailing list