No kernel messages displayed during boot

Dmitry Karasik dmitry at
Mon Nov 19 07:14:59 PST 2007

 Jeremy> Hmm, it looks as if the system doesn't have any indication of what
 Jeremy> the local console is.  I would expect to see a "consolectl" listed
 Jeremy> under the "Configured:" section.  See below for some of the output
 Jeremy> from our systems...

Hi Jeremy,

Thanks for your advice, I've started to dig deeper and deeper until I found
that it was boot0 loader's fault. Strange as it sounds, it is the only
plausible explanation I can think of, because of the all strange effects
I've encountered. 

First, the problem went away when I've replaced /boot/loader with a freshly
compiled one. But the interesting part was, that the change to the new
loader caused a prompt for the location of /boot/loader on the next reboot
(note, no -a in loader.conf!). Next reboots went just fine. The interesting
stuff began when I reverted the loader back, and it worked - but again, 
first time it prompted the input, and worked afterwards. This pattern with
flipping old and new loaders back and forth actually was reproducible,
and most fun of it all, also under qemu, which I used to save time and
used the same /dev/ad4 my system lives on, but in read-only mode. The fact
that that action chain actually presisted between reboots in qemu on a
read-only device -- I don't know, I simply have no explanation to this. 
As a last resort, I've re-run boot0cfg -B , and voila, everything started
worked fine, and the loader prompt effect disappeared.

I'm thinking that something corrupted my MBR in such a nasty way that
some boot0's memory, possibly boot flags word (-a, -D etc boot_ flags 
found in loader.conf) , thought of having been 
initialized to zero, was not. I tried to look at the source of boot0, 
but couldn't figure out first if that's an issue here at all, and second, 
if that behavior would be desirable (after all, the code must be 512 bytes
max).  Nevertheless, that effect was really spooky - imagine a stray bit
in MBR turns off whole console logging!

And at last - the machine crashed when I tried to write on msdosfs
mounted on /dev/md0. Apparently it wrote something it shouldn't 
in the MBR. And I tried to write on msdosfs while trying to figure
out if my old msdosfs kernel PR #47628 is still actual under 6.2.
If anyone's willing to try that, (the PR has perl script attached,, you're very
welcome. Just back up your MBR first :)

	Dmitry Karasik

More information about the freebsd-stable mailing list