No kernel messages displayed during boot

Dmitry Karasik dmitry at
Sun Nov 18 11:29:58 PST 2007


My 6.2-STABLE crashed today, and when I rebooted it, a very strange effect
appeared: from the second the kernel took over, immediately after loading all
.ko files, no text was printed in the console. The system booted though, and
the next text was printed to the console was the login prompt. The screen
didn't went blank, just all kernel messages and output of /etc/rc* wasn't there
-- all was printed on the screen was FreeBSD boot menu, and login prompt.

I've re-run 'make installworld' and 'make installkernel' (as I had leftovers
from recent buildworld), - didn't help. I've tried to power down the machine
(suspecied video card trouble), I've resetted BIOS, I've even disabled com port
in BIOS (because the behavior looks like booting on serial console) -- nothing,
absolutely nothing changes it.

When I tried to boot in single-user mode, the prompt was never displayed at
all, which fact indeed makes me think alogn the path of the wrong boot console.
I've removed /boot/loader.conf, and double-checked that /boot.config isn't
present - didn't help.

My question is therefore, what cause of this effect might be?  Or, if noone
would be able to answer this, how I would print messages from kernel (I'd
recompile it for that purpose) to identify which device it picked up for
console IO -- and especially, how I print that either to a file, or directly to

	Dmitry Karasik

More information about the freebsd-stable mailing list