7.0-BETA1 & 2 occasionally freezing, how to diagnose?

Norberto Meijome freebsd at meijome.net
Mon Nov 5 17:49:00 PST 2007

On Mon, 05 Nov 2007 14:24:09 -0600
Doug Poland <doug at polands.org> wrote:

> Hello,
> I've been having frequent problems with BETA1 and now BETA2 "freezing". 
>      There is no diagnostic information, nothing in /var/log/messages, 
> nothing, just a hung interface.  I cannot ssh into the machine and it 
> appears the box ceases to communicate on SSH. A couple of times I've had 
> screen corruption on the laptop's LCD display.
> Every time it hands I'm running Xorg 7.3, Thunderbird, Firefox, pidgin, 
> and a bunch of xterms.
> Is there something I can do to diagnose this issue?

hi Doug,
My laptops is freezing like this too - no corruption on display though (this is the 2nd time i write this email, as it just happened <G>). I am still not sure what the cause is...some things I've used / tried:

I was using gjournal on my 80 GB /usr  partition, with a 1.5 journal to ad01sh . I was getting quite often lockups where it seemed the disk subsystem would stall - anything in memory would work, but as soon as disk access was needed, it'd stall too. Rebooting was not an option, as the shutdown watchdog would timeout and stop it.

furthermore, I'd have to go into single user and run fsck /dev/ad0s1f.journal every time the laptop would crash. I seemed to have much fewer bad information in the inodes (thanks to the journal), but I was getting 4 or 6 crashes a day. Since I switched away from gjournal, these crashes have completely gone away. since this is my main machine, i cant experiment too much with it.

I also had skype-1.4 running . One of its processes was spinning completely out of control , when i wasn't using skype at all (other than receiving text msgs). I sent an email about it to Multimedia.I've since switched back to skype.1.2 and that problem is also gone.

But i still get the occasional lockup. I have a feeling it is related to using the sound card :

$ cat /dev/sndstat 
FreeBSD Audio Driver (newpcm: 32bit 2007061600/i386)
Installed devices:
pcm0: <Intel 82801F High Definition Audio Controller> at memory 0xb0000000 irq 11 kld snd_hda [20071020_0048] [MPSAFE] (1p:10v/1r:6v channels duplex default)

Pretty much everytime I'm getting a lockup, i'm either streaming music from my music box or on a skype call. Not much to go by, but there isn't any logs left at all of the crash. It is not a panic (no writing dump to disk when I press enter, Caps-lock is dead, even the Fn key which is bound to the bios is dead). What I have noticed in these cases is that there seems to be a lock up....then, about a minute or so after it, the mouse seems to come back to life...but then there's nothing more I can do - i've waited for over 5 minutes after this with no more results....

Not sure how I can diagnose / test this, but i'm willing to give them a try, time permitting :)

{Beto|Norberto|Numard} Meijome

   Mary had a crypto key

   she kept it in escrow

   and everything that Mary said

   the Feds were sure to know.

I speak for myself, not my employer. Contents may be hot. Slippery when wet. Reading disclaimers makes you go blind. Writing them is worse. You have been Warned.

More information about the freebsd-stable mailing list