Can't build threaded perl 5.8 on 6.2-RELEASE and 7-CURRENT

Fabian Keil freebsd-listen at
Thu Feb 8 14:43:50 UTC 2007

LI Xin <delphij at> wrote:

> Fabian Keil wrote:
> > LI Xin <delphij at> wrote:
> > 
> >> It seems that threaded perl is broken on 6.2-RELEASE and 7-CURRENT.  I
> >> have tried some option combinations with no luck, if WITH_THREADED=yes
> >> is specified then the build would fail with a coredump.
> > 
> >> Any hints?
> > 
> > I ran into the same miniperl core dumps a few days ago
> > while trying to switch back to non-threaded Perl (shortly
> > after updating the system to a recent RELENG_6).
> > 
> > The only way I found to "fix" it was to:
> > 
> > - deinstall all Perl ports,
> > - rebuild Perl
> > - reinstall all Perl ports
> > 
> > I assume miniperl somehow included incompatible local
> > Perl libraries, but I didn't really look into it.
> Doesn't work for me...  Do you mean that you have switched back to
> non-threaded Perl, after you have removed all Perl ports?

Yes, but I had intended to switch back to non-threaded Perl
from the beginning and that was when I ran into this.

I had previously removed "WITH_THREADS=yes" in make.conf,
tried to "portupgrade -rf perl" and it didn't work because
Perl itself didn't compile.

I then forcefully pkg_add'ed a non-threaded Perl package
(which made things a bit worse) but still wasn't able
to recompile the p5-Ports. After removing everything
Perl related first, it finally did.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 187 bytes
Desc: not available
Url :

More information about the freebsd-stable mailing list