Can't build threaded perl 5.8 on 6.2-RELEASE and 7-CURRENT

LI Xin delphij at
Thu Feb 8 12:08:54 UTC 2007

Fabian Keil wrote:
> LI Xin <delphij at> wrote:
>> It seems that threaded perl is broken on 6.2-RELEASE and 7-CURRENT.  I
>> have tried some option combinations with no luck, if WITH_THREADED=yes
>> is specified then the build would fail with a coredump.
>> Any hints?
> I ran into the same miniperl core dumps a few days ago
> while trying to switch back to non-threaded Perl (shortly
> after updating the system to a recent RELENG_6).
> The only way I found to "fix" it was to:
> - deinstall all Perl ports,
> - rebuild Perl
> - reinstall all Perl ports
> I assume miniperl somehow included incompatible local
> Perl libraries, but I didn't really look into it.

Doesn't work for me...  Do you mean that you have switched back to
non-threaded Perl, after you have removed all Perl ports?

Xin LI <delphij at>
FreeBSD - The Power to Serve!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 249 bytes
Desc: OpenPGP digital signature
Url :

More information about the freebsd-stable mailing list