Problem adding new slices

Kevin Oberman oberman at
Sun Aug 5 12:02:08 PDT 2007

> Date: Sun, 05 Aug 2007 10:24:21 -0700
> From: Jason Edward Kocol <mrkocol at>
> Sender: owner-freebsd-stable at
> I am running 6.2 STABLE and am having an issue adding new slices to a 
> disk on a running system.  The drive ad0 is 160GB and my original plan 
> was to add slices as I needed them.  I have successfully created slice 
> ad0s1 for all typical mount points, and was even able to create ad0s2d 
> for mount point /c.  The problem now is that I am unable to create a 
> third slice, ad0s3d, on mount point /d.  I've tried using sysinstall to 
> do this, and in the Label editor the final message is:
> Error mounting /dev/ad0s3d on /d : No such file or directory.
> I checked /dev, and sure enough ad0s3d is not in there.  It just never 
> gets created.
> I have tried doing this in several ways; rebooting after using fdisk to 
> create the partition, then running Label editor but the result is always 
> the same.  I even tried moving all the files I had on /c to another 
> machine, deleting that slice (originally 15GB) and creating a much 
> larger one in its place (now 60GB), but the end result of that is the 
> "new" slice is the same size of the old one, even though in the Label 
> editor it shows the new larger size I created.
> If anyone has any suggestions, even bypassing sysinstall entirely and 
> using other utilities, please let me know the exact steps to take.

A bit of a lack of information in yo9ur report.

Please provide the output of 'fdisk ad0' and 'bsdlabel /dev/ad0s3'. My
suspicion is that there is a problem in the slicing, but there is not
any real data in the report on which I can to base that.
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at			Phone: +1 510 486-8634
Key fingerprint:059B 2DDF 031C 9BA3 14A4  EADA 927D EBB3 987B 3751
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 224 bytes
Desc: not available
Url :

More information about the freebsd-stable mailing list