Problem adding new slices

Jason Edward Kocol mrkocol at
Sun Aug 5 10:51:04 PDT 2007

I am running 6.2 STABLE and am having an issue adding new slices to a 
disk on a running system.  The drive ad0 is 160GB and my original plan 
was to add slices as I needed them.  I have successfully created slice 
ad0s1 for all typical mount points, and was even able to create ad0s2d 
for mount point /c.  The problem now is that I am unable to create a 
third slice, ad0s3d, on mount point /d.  I've tried using sysinstall to 
do this, and in the Label editor the final message is:

Error mounting /dev/ad0s3d on /d : No such file or directory.

I checked /dev, and sure enough ad0s3d is not in there.  It just never 
gets created.

I have tried doing this in several ways; rebooting after using fdisk to 
create the partition, then running Label editor but the result is always 
the same.  I even tried moving all the files I had on /c to another 
machine, deleting that slice (originally 15GB) and creating a much 
larger one in its place (now 60GB), but the end result of that is the 
"new" slice is the same size of the old one, even though in the Label 
editor it shows the new larger size I created.

If anyone has any suggestions, even bypassing sysinstall entirely and 
using other utilities, please let me know the exact steps to take.


More information about the freebsd-stable mailing list